Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

DirectX 9.0c issues

This is where you can ask questions and get and give help about hardware related issues. This Forum will be moderated by Taw with help from some other experts. So feel free to ask any questions you may have about computers.

Post Wed Dec 07, 2005 1:23 pm

DirectX 9.0c issues

I knew my PC has issues, but this is just too damn much!

I first had a problem a few weeks ago, when I tried to run Call of Duty 2. It failed to work because I needed a new version of DirectX (9.0c). Ok, so I go to MS site, and download the update. Once I tried to install it, it would begin, but half way it would stop displaying an error message "DirectX did not copy a required file". After a few tries this became aggravating, therefore I decide to google the problem and see what’s the deal. As I find out, I am not only one having probs with 9.0c, and luckily there was a solution. I installed all the directx files manually, ran DXDIAG.EXE and it said 9.0c, WOOHOO my Call of Duty 2 works!

well anyway, today I try to install Civilization IV Demo, and it says I need DirectX. WTH I already have it. But, since the demo starts the DirectX installation automatically I decide to update it again. One problem though, I get the same problem, "DirectX did not copy a required file".

I run DXDIAG.EXE again, just to check it, and it says 9.0c there. I am clueless atm, it would seem that any future game installations will not work, anyone got any ideas about this?


PC SPECS:
Windows XP
Service Pack 1

I dont think anything more is necessary, it seems this is the only thing mentioned in my google searches.

Edited by - Leonhart on 12/7/2005 1:29:39 PM

Post Wed Dec 07, 2005 4:11 pm

Why don't you try installing DirectX manually a second time using the DirectX files on the Civ4 DVD? In any case, there seem to be differing "versions" of DirectX. I just completed F.E.A.R, and I had 9.0c installed, but before I could complete the installation the game required me to install "DirectX 9.0c (August)". Is there really any difference between the two "versions"? Obviously VU seem to think so .

Post Wed Dec 07, 2005 4:29 pm

well I guess I could give it a try, after all the damo was released on november 25th, so there is a possibility my version is outdated by 3 days or so

Post Wed Dec 07, 2005 9:09 pm

It's too bad that you don't have an up-to-date image you could use. A bit o' ghosting would really help about now .

Post Thu Dec 08, 2005 8:15 am

I've been told if you have the same or a newer version of DirectX and it's an OK install, a DirectX installer which is that version or older being run by a program as part of its install seqyence, will not actually copy the files even if it looks like it's doing so.

Edited by - Hahukum Konn on 12/8/2005 8:16:36 AM

Edited by - Hahukum Konn on 12/8/2005 8:17:19 AM

Post Thu Dec 08, 2005 1:35 pm

@Esq, I cant say I know what you mean

@Haku
yea, the thing is that install terminates at about 50%, just sends an error..

Post Thu Dec 08, 2005 2:47 pm

There are some unofficial DirectX uninstallers out there. Perhaps try one of those, and then reinstall DirectX. You may wish to make an imag... restore point before you try that though. Just in case .

Post Fri Dec 09, 2005 4:44 am

if DirectX is causing these sort of problems then there are 2 things going, possibly at the same time; firstly, a knacked up registry, so run NUSW2005 Windoctor from cd (or summat similar) and tidy it up, and secondly, are you *sure* that the games you're putting on are all usingt he same version of DirectX? a lot of my calls are from people who bang on games and just install whatever version of DX is on the cd, so you have 9.0c going to 9 going to 8.1 and even 5 i had the other day.

if DXSetup doesn't find a file to update then it won't copy the file over. DX uninstallers are horrible anyway, I'd rather just reg-clean and reinstall DX, not the websetup but the end-user runtime. it's a self-extracting .exe so it does exactly what it sez on the tin.

Post Fri Dec 09, 2005 6:16 pm

I never said that the uninstallers were *good*, only available .

Post Fri Dec 09, 2005 8:24 pm

yep pritty darn sure. Its 9.0c, checked and triple checked

I did a bit more digging, and found this

MSKB

funny thing is that directory does not even exist...there is no "dxxpdbg" folder in system32 dir, and especialy no dxxpdbg.exe

I guess tomorrow I give a try to the DirectX uninstall. I dont think I got the doctor thing you are refering to taw, but my reg is probably screwed up. I have been planning a reinstall for a while now, but with a few gigs of important things...its a pain in the butt making CD copies of everything.

When I upgraded to 9.0c last time, I used the self extracting files. I still had the problem though, thats why I had to extract all the files manually and copied/pasted them where they belong.



Edited by - Leonhart on 12/9/2005 8:32:45 PM

Post Fri Jun 01, 2007 2:59 pm

Has anyone found if there's a problem using the October 2006 or April 2007 DirectX 9.0c installer? (The DirectX 9.0c that comes with XP Service Pack 2 is an older one)

Return to Hardware

cron
Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.