Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

Having slight problem with retexturing Anubis

Here you can discuss building custom ships, texturing and 3D modeling in Freelancer

Post Tue Jun 19, 2007 7:15 pm

Having slight problem with retexturing Anubis

Ok I might as well say it, i've been working on a mod called Dark Worlds. Well I dicided to start the dark world ships, starting with the dark Anubis. Well it works great. The new Texture (Same texture just burned in Photoshop) works so far. But in the ship selection screen, the Anubis and the Dark Anubis both have the same texture. (I created an new *.mat file for the Dark Anubis called or_ships_dark.mat)

Is there anyway to fix without changing much this or will I have to export the ship to milkshape to assign new groups then come back and create an band new texture. (My Photoshop skills aren't all that good. And my last time I tried to create an texture from scratch (Over an year ago) the game crashed.)

Thanks in Advance.

This is what happens when you try and dock rape. (This is not me) Noobs trying to dock rape

Post Wed Jun 20, 2007 12:46 am

you cant simply create a new mat because of different groups
you would create crc errors this way

either you export the model again or u use the mod el cloner to adjust the names of the materials and cmps to fit each other

Post Wed Jun 20, 2007 11:28 am

nvm i found it. Search feature is broke lol. had to find it manually


Edited by - 5i1 2 on 6/20/2007 12:33:26 PM

Post Wed Jun 20, 2007 12:21 pm

Well I cloned the model and gave everything an unique name but it ends up black in Hard CMP, with no Hard Points.

Pictures:

Post Wed Jun 20, 2007 1:23 pm

Sounds like the cloner screwed up the CMP settings( not unusual).

When cloning keep the changes simple, 1 or 2 letter/number changes for each item.

This is the sort of thing I use when I'm experimenting-

VMesh IDs

data.ships.order.or_elite2.or_elite2.lod2-112.vms
data.ships.order.or_elite2.or_elite2.lod1-112.vms
data.ships.order.or_elite2.or_elite2.lod0-112.vms

3DB Names

Or_star_wing_lod10184912555.3db
Or_port_wing_lod10184912555.3db
Or_glass_lod10184912555.3db
Or_Engine03_lod10184912555.3db
Or_Engine02_lod10184912555.3db
Or_Engine01_lod10184912555.3db
Or_elite_lod10184912555.3db
baydoor02_lod10184912555.3db
baydoor01_lod10184912555.3db

Material IDs

elite2_256OR
engine_bjOR
O_glass
lib_weap2OR
metal03OR
weaponplate2
elite2_2562sideOR

The cloner has problems if it has to add a lot of bytes to the file, so by keeping the VMesh IDs and 3DB Names more or less the same size you stop this, those names are stored in the CMP as you see them rather than CRCs.

With the 3DB Names I only change the numbers as the letters refer to the part that both the SUR and Destructables are looking for (my numbers are usually the decimal # code of the model name).

When it comes to the Materials I only change the ones I'm creating new textures for, O_glass, metal03OR & weaponplate2 are untouched so I leave them, engine_grill01 became enginebjOR only because I'm using a glow map on it.

You'll find that you can delete most of the nodes in the new MAT file as most of them are for the Osiris, your ship will only use 7 Materials and 5 textures, if your doing the damage 3db's as well then you'll need to keep thier Materials as well, 1 small tip though, they don't clone, it's hex editing time to do them.

**shuffles off with a new headache**

My bad, I can't count it's 7 materials and 5 textures and 9 and 7 if your keeping the damage materials.

Edited by - Bejaymac on 6/20/2007 2:47:01 PM

Post Wed Jun 20, 2007 4:59 pm

Ok thanks It works now.


Screenshot:

It turned out better than I expected.

Return to Freelancer 3D Modeling and Texturing Forum

Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.