Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

Bug with my new ship... Dunno why help plz (Fixed)

Here you can discuss building custom ships, texturing and 3D modeling in Freelancer

Post Tue Jul 20, 2004 7:02 pm

Bug with my new ship... Dunno why help plz (Fixed)

I get this log in FL Server whenever I try to go into space with my new ship :
E:\FL\Scratch\Source\Common\physys.cpp(533) : *** ERROR: BuildPartIVP_Real(): No surface input for part_arch
E:\FL\Scratch\Source\Common\physys.cpp(634) : *** ERROR: BuildIVP_Real(): failed to create ivp_real for part (Root) in file (SHIPS\BOSTON\SABERTOOTH\interceptor.cmp).
E:\FL\Scratch\Source\Common\CShip.cpp(1479) : *** ERROR: CShip::init_physics(): Failed to create ivp_real for SHIPS\BOSTON\SABERTOOTH\interceptor.cmp. Expect a crash.

Symptoms :
-The ship appears nowhere in the ship dealer nor on the liftoff screen, but it appears in the small 3D interactive view of the ship dealer.

-I followed Dritzz's tut with another ship. Didn't do any gun btw.

What is the problem??? Searched everywhere for this error log without any result...

Edited by - Friendly_fire on 7/27/2004 1:27:12 PM

Post Tue Jul 20, 2004 7:35 pm

is the E: drive your cdrom? or do you have a wierd install on your computer?

Post Wed Jul 21, 2004 5:01 am

The E: Drive is my second disc and I dunno why it uses it as a temp file but the problem's not there I think...

Post Wed Jul 21, 2004 5:51 am

Here is a full log from the startup of the server to the crash :

Chargement des données initiales...
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(1111) : NOTICE:General:Current DACOM.DLL version: 1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(1112) : NOTICE:General: Compiled against version: 1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(852) : NOTICE:GeneralACOM: initialize: dllpath: 'C:\Program Files\Microsoft Games\Freelancer\EXE\'
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(880) : NOTICE:GeneralACOM: initialize: Loading DLL's from [Libraries group.
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\readfile.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\engbase.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\x86math.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\rendcomp.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\system.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\Thorn.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\DebugLib.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\rp8.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:GeneralACOM: AddLibrary: DLL 'C:\Program Files\Microsoft Games\Freelancer\EXE\shading.dll' [1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\RenderPipeline\DX8\rp_dx8.cpp(763) : NOTICE:General:RenderPipeline
C:\work\builds\dalibs\dalibs-build\build\Src\System\SysContainer.cpp(291) : NOTICE:General:SystemContainer: LoadSystemComponents: Loading 'DirectX8' [ returned [OK
C:\work\builds\dalibs\dalibs-build\build\Src\System\SysContainer.cpp(291) : NOTICE:General:SystemContainer: LoadSystemComponents: Loading 'MaterialLibrary' [ returned [OK
C:\work\builds\dalibs\dalibs-build\build\Src\System\SysContainer.cpp(291) : NOTICE:General:SystemContainer: LoadSystemComponents: Loading 'TextureLibrary' [ returned [OK
C:\work\builds\dalibs\dalibs-build\build\Src\EngBase\Engine\engine.cpp(508) : NOTICE:General:ENGINE::load_engine_components: aggregation of 'Animation' [ returned [OK
C:\work\builds\dalibs\dalibs-build\build\Src\EngBase\Engine\engine.cpp(508) : NOTICE:General:ENGINE::load_engine_components: aggregation of 'Hardpoint' [ returned [OK
C:\work\builds\dalibs\dalibs-build\build\Src\EngBase\Engine\engine.cpp(508) : NOTICE:General:ENGINE::load_engine_components: aggregation of 'RenderManager' [ returned [OK
E:\FL\Scratch\Source\Common\GoodList.cpp(450) : *** ERROR: Cannot open goods file ..\data\equipment\engine_good.ini
Démarrage de la thread logique...
Serveur en cours d'exécution, prêt à se connecter.
E:\FL\Scratch\Source\Common\Systems.cpp(3044) : *** WARNING: get_system(LI06) failed.
E:\FL\Scratch\Source\Server\PlayerDB.cpp(886) : *** ERROR: game () has invalid system name (LI06) in player file (C:\Documents and Settings\Jean-Philipe Guertin\Mes documents\My Games\Freelancer\Accts\MultiPlayer\23-527b8c08\05-29ea9b46.fl)
E:\FL\Scratch\Source\Common\Systems.cpp(3071) : *** WARNING: get_base(LI06_01_Base) failed.
E:\FL\Scratch\Source\Server\PlayerDB.cpp(902) : *** ERROR: game () has invalid last_base name (LI06_01_Base) in player file (C:\Documents and Settings\Jean-Philipe Guertin\Mes documents\My Games\Freelancer\Accts\MultiPlayer\23-527b8c08\05-29ea9b46.fl)
LOG: Login on account f5f83e81-446e58ce-d351f930-b8c9b3a8 ("C:\Documents and Settings\Jean-Philipe Guertin\Mes documents\My Games\Freelancer\Accts\MultiPlayer\23-527b8c08"
E:\FL\Scratch\Source\Common\physys.cpp(533) : *** ERROR: BuildPartIVP_Real(): No surface input for part_arch
E:\FL\Scratch\Source\Common\physys.cpp(634) : *** ERROR: BuildIVP_Real(): failed to create ivp_real for part (Root) in file (SHIPS\BOSTON\SABERTOOTH\interceptor.cmp).
E:\FL\Scratch\Source\Common\CShip.cpp(1479) : *** ERROR: CShip::init_physics(): Failed to create ivp_real for SHIPS\BOSTON\SABERTOOTH\interceptor.cmp. Expect a crash.

Post Wed Jul 21, 2004 7:02 am

Do you really have an Li06 system?? Did you make one?

Post Wed Jul 21, 2004 7:56 am

Ya I made a new system for an upcoming Ship Pack and now the mod was deactivated, but I still had a MP char in this system. But my ship is for sale at Manhattan.

Post Wed Jul 21, 2004 9:26 am

Ok now it's even worse... I tried to modifiy some things into the cmp and mat files of my new ship and now whenever I try to go to the Ship Dealer, I crash to desktop...

But the server no more crash and no more error in the log.

P.S. : Forgot to say I got no light nor pilot/cockpit and no weapon except mines and CM.

Edited by - Friendly_fire on 7/21/2004 10:39:28 AM

Post Wed Jul 21, 2004 2:29 pm

Have you tried using Crabtree's AWESOME Shipscripter? It sounds like you have some problems in your goods.ini if the lights and such don't work...also could be causing a crash as well. Do a search in the download section here for "Shipscripter" and it might help. Also, a tip for Shipscripter - you don't have to use the script it makes, you can copy and paste the information it generates into the appropriate files (i.e. - good.ini, shiparch.ini, etc) and that might solve at least some of your problems...





Edited by - baene on 7/21/2004 3:30:57 PM

Post Wed Jul 21, 2004 3:14 pm

Shipscripter creates a lot of errors so follow the instructions carefully.

If you like you can send me the .ms3d file and I'll try exporting it to .cmp for you.

Post Wed Jul 21, 2004 3:50 pm

What sort of errors are you talking about, PantherX? I've used Shipscripter on 40 ships now, and it hasn't made any errors for me lol...If you don't USE it right, it can be a headache, but the tutorial added makes it pretty simple (if you read it hehe, i didn't at first, but i recommend you DO read it if you use the tool).

Baene

Edited by - baene on 7/21/2004 4:51:21 PM

Post Wed Jul 21, 2004 4:50 pm

Chips helped me and now I can see the ship but I still get a server crash when I try to launch...

It is now 99% sure it's a model bug...

The zip of the model and of the texture (gray square) are found there :
http://rasquad.250free.com/System_mod/i ... orking.zip

Post Wed Jul 21, 2004 7:05 pm

Ok at first glance at the mesh in milkshape;

1./ You have assigned a material to all your hardpoints which is a no no (it should say 'No material')
2./ You have no weapon mounts (Hp/revolute/HpWeapon0x or Hp/revolute/HpTurret0x) on your ship.

These may not cause of the crashes but they definitely are not good.

Post Wed Jul 21, 2004 10:00 pm

I'm trying to make a Homeworld2 ship (Vaygr Lance fighter) in ms3d. I used the hodviewer to extract the objects and textures from HW2 (meshes are no longer .peo but .obj).
The obj importer gets it into ms3d. I can extract them with/ without inverted UVs, the following problem arises. Also, if I run model cleaner or not, same thing.
If invert UV isn't selected, object appears black in ms3d, but model cleaner fixes it.
the hodviewer extracts 2 or 3 .dds files per object in the mesh. I merged these into one .dds using layers in photoshop 7 (w/ nvidia plugin). Apparently they need to be flipped as well.
When I apply these to my model in ms3d, the model develops those black holes from inverted vertices. When I remove the texture, the inverted vertices remain. This happens no matter what state my model was in.
Can any one shed some light on this?

Post Thu Jul 22, 2004 6:20 am

Still get this :

E:\FL\Scratch\Source\Common\CEqObj.cpp(463) : *** WARNING: alloc_equip: Archetype[0x8000bec6 not supported/equippable!
E:\FL\Scratch\Source\Common\CEqObj.cpp(463) : *** WARNING: alloc_equip: Archetype[0x8000bec6 not supported/equippable!
E:\FL\Scratch\Source\Common\physys.cpp(533) : *** ERROR: BuildPartIVP_Real(): No surface input for part_arch
E:\FL\Scratch\Source\Common\physys.cpp(634) : *** ERROR: BuildIVP_Real(): failed to create ivp_real for part (Root) in file (ships\BOSTON\SABERTOOTH\interceptor.cmp).
E:\FL\Scratch\Source\Common\CShip.cpp(1479) : *** ERROR: CShip::init_physics(): Failed to create ivp_real for ships\BOSTON\SABERTOOTH\interceptor.cmp. Expect a crash.

What's weird is that my ship is upside down and looks rotated of 90 degrees...

Anything else?

Post Thu Jul 22, 2004 9:35 am

I just got had an idea... Could this error be caused because I have no sur file?
Surface_input could mean it cant find collison params?
Next

Return to Freelancer 3D Modeling and Texturing Forum

cron
Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.