Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

FL Rebalance 3.50 Mod suggests, comments and bug report thre

Here you can find news, get help and comment about the ?FL Rebalance Mod? for Freelancer

Post Fri Mar 03, 2006 1:00 pm

bri, there was a mistake in the instalations instructions, telling you to install RB 3.30 after instaling v3.5,as spearhead said, DON'T DO THAT....it was a typo in fact it was meant to say: "install RB 3.50"!!
If you're playing OpenSP, make sure you're choosing one of the 9 OpenSP starting characters, not the default Normal Player one.
Most of the RB players did not report instability when playing, don't know why you or Spearhead has so many CTD's...on the test systems I ran every SP character up to level 35 with almost NO CTD, also played the whole SP campaign more than 10 times with very RARE CTD's....perhaps the mod it's not 100% foolproof, but ut should not behave as you describe it apparently does on you PC's...
If you want not to blow up in Carolina, take a ship with an armor above 9000 and some armor enhancement, also keep your nanos pool filled, and you'll pass the system with no big probs...land on Columbia Transit to replenish your nanobots if you need to...

Post Fri Mar 03, 2006 4:55 pm

ill try a diff char. i belive i put outcast and i know i put outcast for something. however i was also using a no modded save file for after the game. also did you take the raven claw out or move it to a diff location then earlyer mods? other then that i love the mod, despite the CTDs. thanks

Edited by - warrior17 on 3/3/2006 5:21:46 PM

Post Fri Mar 03, 2006 10:42 pm

the raven claw was moved, not taked out.
warrior17: don't use anyomore unmodded save files, remove them all before even starting FL with Rebalance 3.5 installed, it may be the cause of your crashes.

Post Sat Mar 04, 2006 12:38 am

when i installed the mod, i first opened FLMM and opened the mod folder, created a new folder and renamed it RB3.5, i then opened the zip file and just copyed the files over, and it works just fine

all of my questions are answers to my sins.and all of my endings are waiting to begin

Post Sat Mar 04, 2006 5:18 am

We still get some problems with capships. Most of the time, when the player tries to launch after buying the capship and they get booted for "cheating".

For the Defiant, we found a workaround: buy new engines and you can play with it. Tho, you do lose out on the nice speed that the default engines give you.

We noticed 1 station so far that doesn't let you launch if yer in a capship - you sit in the hangar and die... we have since stopped visiting stations w/capships in MP.
(I wish I remember the station, but I was frustrated -- it was in the liberty system I think - we were headed towards kusari space)

Other than that, we played for 9 hours STRAIGHT in MP last night... the only thing that crashed the server was earth alliance system. We set the density to MED, perhaps we need to go even lower... we got about 4 crashes of the server when we were both in earth alliance system and in different areas with lots of enemies/allies.

I am using a Sovereign and my buddy is in the defiant... I find if I approach the tradelanes from their 'center' and from 'straight-on', I have no problems.

Ah - the only other bug we found was the station at EARTH - sometimes it launches you TOWARDS the planet... and if yer in a large cruiser yer atmosphere toast. You have to respawn until it decides to launch you to the 'space side'.

We are going to play some more today and I'll bring a pad of paper and jot down all the bugs..

GREAT mod though... definately breathed new life into freelancer...

Post Sat Mar 04, 2006 9:20 pm

The mod is working fine for me. I have had the odd server crash for no apparant reason though.. Strange indeed. Would be nice if some other players gave MP a try and we could then gauge better how things are working on the server.

ATGFL Rebalance 3.50

Post Sun Mar 05, 2006 9:23 am

There was indeed a bug in easy mode, there were 2 Starblazer loadouts that were left out, so that's why the mod could crash while using this setting. I already fixed this and a patch will be posted soon on TLR, that fixes these CTD's in easy mode. You'll have to unzip it directly in FLMM's Mods\FLrebalance350Full folder in order to work though.

Edited by - Michael_Dan on 3/5/2006 9:23:41 AM

Post Sun Mar 05, 2006 4:59 pm

Ok, finally got this thing figured out. For those of you that are having problems try my steps.

1). Delete the FL folder completely or any saved game files.
2). Install A brand new spankin copy of FL and restart
3). Install the newest version of SDK available
4). Install FLMM
5). Go to FLMM's folder then in it go into the mods folder and create a Folder called FLRebalance 3.5
6). Sence this mod is deliverd in ZIP, Extract all of the mods contents into your FLMM'S/mods/FLRebalance 3.5 folder.
7). Edited: At your disgretion Move the .exe that came with the mod for FL into FL's exe and choose to replace the old exe with the new one. Or you can remove the old exe and save it somewhere and put the new one in there.
8). Go to FLMM, Activate the mod (should show up under the FLMM'S mod list) FL Rebalace 3.5 Full, Now u should get an option to choose how u want to start your game off.

9). Enjoy

No Probs with mod as of yet... Hope my lil steps helped u guys .. .cuz i was lost at first :'(!

O and ty for that ahum step #7 ahum :X

Edited by - SinisaD on 3/6/2006 12:43:57 PM

Post Sun Mar 05, 2006 5:39 pm

never had a problem with the orginal SFs causing the problems. however was using ships form the mod, wonder if it could be the invitory list...some old weapons...but like i said, never had problems with 3.4 cept in story line. ill try it though. thanks

Post Mon Mar 06, 2006 12:06 pm

I wnat to inform all Rebalance fans that the new Rebalance site, that contains (for now) a forum and a downloads section can be found here: http://www.rebalancemod.gameshack.avidao.com/, and it also contains Rebalance 3.50 full and the 1.01 patch, that includes the Easy mode patch and the MP patch from Polyfiller...

Post Mon Mar 06, 2006 12:25 pm

@ Warrior, the white ships are caused by 1 of 2 things, 1 several ships all have the same component names in the CMP or MAT file meaning they conflict with each other and give you an untextured ship or 2 your graphic's card can't handle one of the texture formats FL uses, as you've mentioned this before with other mod's I'm tempted to suggest it's your card. Check with the card makers and see if they can help, also let me know what ship's your having problems with and I'll check the MAT's to see what type of texture was used, see if I can help narrow it down a bit.

@ SinisaD, step 7 is a bad idea as MD's using a hacked exe with RB 3.5, this will cause problems with Vanilla FL and any mod that doesn't have it's own exe.

**shuffles of with a new headache**

Post Mon Mar 06, 2006 4:45 pm

probly video card, however i have to redownload everything. mods, flmm and others. all this because my hard drive that i stored everything on crashed...

Post Thu Jun 08, 2006 1:53 am

weird thing. i had reb 350 working perfectly on a computer. for electrical reasons, it burned . i had installed the game into another computer, following the perfect identical steps and 80% of equipments, commodities, etc are shown as "ISDF?". i have tryed 8-9 times new different inslalations, new flmm 14 beta, sdk, fix, no result. WHAT THE WORLD IS MY PROBLEM???

Post Mon Jun 12, 2006 4:53 am

It's obviously an XML database error, caused by a missing or unreadable DLL file, this ussually occurs on older operating systems, prior to XP, such as Win98, Windows NT or Windows 2000...

Post Tue Jun 13, 2006 3:07 am

I have been using the new rebalance 350 mod for only a few days and even after a clean install of everything i still get crashes when i use ships such as the defiant or voyager, and the crashes are always at random without any error messages. Can anyone offer any suggestions
PreviousNext

Return to FL Rebalance Mod

Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.