Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

Mission Problem Urgent

The general place to discuss MOD''ing Freelancer!

Post Wed Oct 17, 2007 6:11 am

Mission Problem Urgent

I have a really anoying problem...in the mission where you have to find ashcroft when you first enter california(I think) you have to wait by the tradelane and scan some ships untill you find the "unknown" ship...then you have to fire a=on it until you disable it's engines...here's the problem...I fire on it ant at some point the ship becomes invulnerable...I fire on it and the shields won't go down...there is about 20% of the Unknown ship's shield still on and it just stays like that no matter how mch I shoot...I presume the problem is caused by the thing that makes juni and king's ships invulnerable in the game...can someone please help me fix this

Post Wed Oct 17, 2007 8:30 am

It sounds like a missing trigger point or Act = line.
This m02.ini excerpt is taken from the m02 folder.

[Trigger
nickname = give_up_cosmo
system = Li03
Cnd_HealthDec = PEscort1, 0.500000
Act_StartDialog = cosmo_giveup
Act_SetVibe = King, PEscort1, REP_FRIEND_MAXIMUM
Act_SetVibe = PEscort1, Player, REP_FRIEND_MAXIMUM
Act_SetVibe = PEscort1, King, REP_FRIEND_MAXIMUM
Act_SetNNObj = stand_down
Act_LightFuse = PEscort1, mission02_cosmo_burning_fighter_fuse
Act_SetOrient = PEscort1, 1, 0, 0, 0
Act_CallThorn = missions\m02\m02_cosmo_01.thn, PEscort1
Act_PobjIdle = no_params
Act_ActTrig = revert_cam
Act_AdjHealth = us, 0.750000
Act_NagOff = nag_battle1


=========================================
I'd start my search for something missing around there.
Of course if Cosmo dies, the mission is supposed to fail and you're supposed
to reload back to the point where you just enterend the Colorado System.

Post Wed Oct 17, 2007 11:34 am

[Trigger
nickname = give_up_cosmo
system = Li03
Cnd_HealthDec = PEscort1, 0.500000
Act_StartDialog = cosmo_giveup
Act_SetVibe = King, PEscort1, REP_FRIEND_MAXIMUM
Act_SetVibe = PEscort1, Player, REP_FRIEND_MAXIMUM
Act_SetVibe = PEscort1, King, REP_FRIEND_MAXIMUM
Act_SetNNObj = stand_down
Act_LightFuse = PEscort1, mission02_cosmo_burning_fighter_fuse
Act_SetOrient = PEscort1, 1, 0, 0, 0
Act_CallThorn = missions\m02\m02_cosmo_01.thn, PEscort1
Act_PobjIdle = no_params
Act_ActTrig = revert_cam
Act_AdjHealth = us, 0.750000
Act_NagOff = nag_battle1

[Trigger
nickname = heal_cosmo
system = Li03
Cnd_HealthDec = PEscort1, 0.500000
Act_AdjHealth = PEscort1, 1.000000

[Trigger
nickname = cosmo_die
system = Li03
Cnd_Destroyed = PEscort1, 1, ALL
Act_ChangeState = FAIL, 21600

Post Wed Oct 17, 2007 11:38 am

that's what I have in m02.ini so there's nothing missing I think...shoud there be some trigger that would make cosmo give up when his HP drops to a specific number? the problem is I can't even disable his shield...so there must be somthing rly screwed somewhere...I noticed that the exact thing happens if I try to destroy king in the same mission...I need sugestyions because I'm not sure where to look but if you tell me I'll know what it's about, cuz most of the freelancer inis are self explanatory so they're not too hard to tamper with.

Post Wed Oct 17, 2007 5:46 pm

A question comes to mind:
did you at any time use any mod that altered shields or included altered shields?

If so, unless you know where to start looking for those changes,
you're only option might be to completely uninstall the game,
then install the game again like you just took it out of the box.
Aside from that:
The only really easy quick fix I can think of in this instance
(since you've only reached mission 2) is to uninstall the game
and do a new install.

If you have used a mod before, I'd start checking in that mod folder where the
changes affected shields. In such a case, it could have also altered the npc shields in the story line. In effect, rendering the mod unusable in SP.

Post Thu Oct 18, 2007 9:16 am

I am using the nearly invulnerable shield mod from the mod manager...that might be it...funny...I've been using it for a really long time and this is the first time I've had problems...I'll check it out and post if I find the problem or not...as for reinstalling the game...tried it...tried starting the game fresh with no savegames but still I have the problem...BRB I guess

Post Thu Oct 18, 2007 11:19 am

I've used that mod before, but didn't have any related problems trying to
disable Cosmo during that fight. That's really odd.

Return to Freelancer General Editing Forum

cron
Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.