Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

Mbases/Universe.ini Headache

The general place to discuss MOD''ing Freelancer!

Post Thu Oct 11, 2007 9:10 am

Mbases/Universe.ini Headache

Hi Again
I've got this problem, NPCs Don't show up in Bars and neither do missions. This only applies to New Bases, and last time it was resolved by Removing Duplicates in Mbases.ini Now, This time I've removed all Duplicates from Mbases.ini and Universe.ini, and it's still playing up...
Any suggestions as to what might be causing this?

Post Thu Oct 11, 2007 10:15 am

Corrupted file, mbases.ini as far as I can remember - the one that defines who appears in bars etc.

Probs something around an = sign, under the heading.. the start of the line is missing, or basically it's two lines in one (like base = blah blah blah = blah blah blah)

when it should be

base = blah blah blah
line = blah blah balh

Take a look at new entries, and then at some originals. You'll spot it

Post Thu Oct 11, 2007 11:02 am

I can't spot that... it would be Under [GF_NPC would it not?

Post Thu Oct 11, 2007 11:47 am

If there is no NPC at all, then it might have to do with something about the whole mBase entry, not just the specific NPCs.

Best way to go is methodically: first take an existing and working mBase entry and swap it out so it's associated with your new base. Then, see if the NPCs show up in the game. if they do, your mBase entry is the issue. If they do not, try doing the opposite: swap out your mBase entry so it's associated with an existing base. If the NPCs show up at that base, then your custom base's the issue. If they do not, both your base and your mBase entry are problematic, in which case it might be better to restart from scratch

Make sure your mBase is NOT a BINI decrypted one. It must come from the SDK, otherwise it's prone to have decryption errors. Make also sure you based your new mBase entry on an SDK entry, not a directly decrypted one.

Hope this helps!
FF

Post Thu Oct 11, 2007 1:51 pm

Aahh!!! the dreaded mBases.ini, Nooooo take it away it's been a while since I last did anything with the mBases.ini, last time was to rebuild a 10Mb one, nightmare.

No NPCs at all - FL stops reading the mBases.ini from the first error it finds, this can be as little as one silly typo hiding in the file, or as much as a completely screwed base entry. If none of the debugging tools can find it then you have a couple of choices, do as FriendlyFire suggests and swap entries around, or jump in and out of bases in game, trying to find the last base with NPCs, or spend several hours eyeballing the mBases.ini trying to find the bloody error.

Only Dealers - This is caused by an errant base entry in the mBases.ini, duplicate entries cause this, but so does having an entry for a base that doesn't exist in the Universe.ini.

**shuffles off with a new headache**

Post Thu Oct 11, 2007 2:12 pm

that would explain it... is there a quick way to find non existant bases, or do i have to spend hours searching the file?

Post Thu Oct 11, 2007 5:45 pm

flscan?

Post Thu Oct 11, 2007 8:45 pm

Do a search and replace for 'offers_missions = mission_type'

should be
offers_missions = true
mission_type = DestroyMission.....

The original algorithm didn't compensate for the missing 'true' statement
DA saved a few bytes by not writing it. Because if offers_missions is present, then obviously it's true. They saved even more by omitting the whole thing if it was false.

Hope this helps.
P1p3r

Post Fri Oct 12, 2007 12:41 am

Nothing on the Mission type thing...
FlScan Only manages to find errors within Existing FL Files... So Far it's not helped me at all.

Post Fri Oct 12, 2007 1:20 am

Don't forget FLini Analyzer and FL Error Checker.

Post Fri Oct 12, 2007 1:25 am

Maybe you could post the code for the bases that aren't working.

Post Fri Oct 12, 2007 4:27 am

well... Thats all of them. All New bases have no Missions. They did before.
I'll post an Entry

Post Fri Oct 12, 2007 4:41 am

Wait, I have a Better idea. If I post a link to the Mbases.ini File Here, Perhaps someone could skim through it and take a look at it. Link is here... it's 1.6 megs

http://www.box.net/shared/hsy9b00ac8

Post Fri Oct 12, 2007 5:55 pm

Just a super-quick glance at your file...I scrolled to the bottom and pasted a sample:

[BaseFaction
faction = gd_z_grp
weight = 9
npc = li0305_001_f

[BaseFaction
faction = co_ic_grp
weight = 9

[BaseFaction
faction = co_vr_grp
weight = 9
offers_missions = true
mission_type = DestroyMission, 0.000000, 0.205130, 100

[BaseFaction
faction = gd_bh_grp
weight = 9
offers_missions = true
mission_type = DestroyMission, 0.000000, 0.205130, 100
npc = li0305_002_m

See how the second and third one have no npc line?

Post Sat Oct 13, 2007 1:25 am

Even if I had no NPCs in the base from that faction that would still affect it right?
Next

Return to Freelancer General Editing Forum

Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.