Freelancer Community Network


Important Message

You are browsing the archived Lancers Reactor forums. You cannot register or login.
The content may be outdated and links may not be functional.


To get the latest in Freelancer news, mods, modding and downloads, go to
The-Starport

(Yet Another) FLE Problem

The general place to discuss MOD''ing Freelancer!

Post Mon Oct 08, 2007 11:58 am

(Yet Another) FLE Problem

Hi People.
After Reformatting my PC I get This Error when i try and save after Inserting a New Object into FLE: An Error Occured during the Update of the empty_dll
It's rather frustrating, and my new object's infocards, names, etc appear blank in game.

Could someone give me a hand?
Thanks
Ruppet

Post Mon Oct 08, 2007 1:52 pm

So, you reformatted your hard drive, eh?
Problems with FLEx, data cards, and the .dll for your mod...

Sorry mate, I'm not psychic here..
If you don't mind.. post here what you did (in detail)
to get where you are now?
1. Installed Freelancer (check)
2. Installed FL SKDK first?(what version and where did you install it)
3. Installed FL Explorer ? (what version)
4. How about your mod .dll? What version of the SDK and FLEx did you use to create it before you had to reformat?
(Just want to help you check all your angles here)

Post Mon Oct 08, 2007 4:42 pm

I think you perhaps may have a bad blank .dll file, FLE has one called empty_resources.dll which it copies to one named my_mod.dll and then inserts the new infocards and string tables into it.

Look for it, it may even not be there perhaps. But if it is, then you may need a new copy, or download FLE again and re-install it.

Let us know the fix, I'm curious.

Roleplay: - the art of self-deceipt!

Post Tue Oct 09, 2007 2:47 am

Something to the dlls. Lately my FLE goes strange on that. When something I insert into a system and it uses a name that is allready in my mods dll FLE takes this one. But if I enter a new name, FLE allways wants to create a new dll.

Post Tue Oct 09, 2007 3:26 am

Thanks Startrader, It works now. I reinstalled FLE and I no Longer Recive the Error. I'm Guessing you were right then.
Thanks Mate

Edited by - Ruppetthemuppet on 10/9/2007 4:26:15 AM

Post Tue Oct 09, 2007 3:28 am

Oh Damn... Then again. It doesn't. I Don't know what version of FLE I Used at first. is there a way of telling?

Post Tue Oct 09, 2007 3:43 am

I got it working. I replaced the empty_resources.dll with my own Mod's DLL. It works fine now.

Post Tue Oct 09, 2007 5:04 pm

Good news.

Roleplay: - the art of self-deceipt!

Post Sun Oct 14, 2007 7:06 am

FLE requires registry entries to function properly. When you reformat or reinstall windows you have to also reinstall FLE, just copying the files doesn't work. Something to remember in the future.

Post Mon Oct 15, 2007 7:56 am

And can you tell me something about my problem, Lova-Deus?

Post Mon Oct 15, 2007 3:42 pm

Simple really. FLE only edits its own DLL files. Once you rename the DLL and define it in freelancer.ini the editor can no longer see it or edit it, so it will always create a new file.

Post Tue Oct 16, 2007 2:42 am

the dll was created by FLE. I just moved it into the EXE-folder.

Post Tue Oct 16, 2007 4:38 am

That's your problem, you went and moved it. Leave it where FLE makes it, then when you activate your mod FLMM puts it in the EXE folder and adds it to the freelancer.ini for you.

**shuffles off with a new headache**

Return to Freelancer General Editing Forum

cron
Hosted by The-Starport
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.